Frage an box-api – Wann funktioniert die Box v1 nicht mehr?

3

Ich versuche festzustellen, welche Version der Box-API ich verwenden soll. Meine Entscheidung hängt von der Zeitachse von EOL der v1-API ab. Ich möchte meine App nicht beenden, und kurz vor (oder kurz nach) der Veröffentlichung der App funktioniert die v1-API nicht mehr.

Ich würde gerne die v2-API verwenden, aber ich schreibe eine C # -App. Da es ein C # SDK für die API v1 gibt, wäre es (kurzfristig) bequemer, die API v1 zu verwenden. Aber wie gesagt, ich mache mir Sorgen um die EOL der v1-API.

Ich weiß, dass Filburt, aber es gibt keine Informationen auf der Box-Website zu diesem speziellen Thema. Die Foren bei Box zeigen auf StackOverflow. Vance-Turner

Deine Antwort

1   die antwort
7

die v1-API zu deaktivieren. Die v2-API wurde ein Jahr zuvor allgemein verfügbar gemacht und im März 2012 als Beta-Version veröffentlicht.

Wir haben unseren Support für alle aktiv genutzten Apps, die auf der v1-API basieren, um weitere drei Monate verlängert. Danach wurde der Support für die v1-API eingestellt.

Die v2-API hat sich inzwischen gut bewährt und weist eine etwa dreifache Leistung sowie eine um 10 bis 20% größere Oberfläche auf, die für die Verwendung verfügbar gemacht wird.

Die V1-API wurde am 15. Dezember 2013 offiziell als veraltet eingestuft. Die Dokumentation zur Migration wurde Anfang 2013 veröffentlicht und bis Oktober 2013 aktualisiert. Peter
Danke für die ausführliche Antwort. Vance-Turner

Verwandte Fragen