Pregunta sobre browser, conflict, javascript, netscape, jquery – Conseguir que jQuery funcione con Netscape 7 y 8

0

Netscape no lee mucho jQuery escrito. ¿Qué pasos toma para superarlos y qué parte del mercado toman los usuarios de netscape?

¿Tiene algún dato que indique que la audiencia de su sitio utiliza Netscape 7 y 8? Si no, no te molestes con esos dos. montrealist

Tu respuesta

3   la respuesta
5

Pasos que tomaría:

Deja que falleEspere a que los usuarios de Netscape se den cuenta de que están utilizando un navegador inactivo con agujeros de seguridad.

La participación de mercado de Netscape es tan cercana a cero como la que importa.

0

Umm, 0%?

Habiendo dicho eso, debo admitir que jquery falla en muchos sitios mientras el prototipo funciona, en mi antiguo Konqueror 3.5.10, así que quizás haya un patrón aquí.

0

Aunque crecí en Netscape ;-) ...Ya no se mantiene (R.I.P)

Por lo tanto, tanto como lo soy todo para el mantra "soporta todos los navegadores", apoyar a los usuarios de una tecnología ahora "muerta" parece una tarea difícil.

IIRC, elmatriz de soporte jQuery se basa en admitir la última versión principal compatible de un navegador principal (y 1 nivel anterior).Netscape 7 y 8 están excluidos de esta lista.

Yo sugeriría un simple aviso de "Actualizar" para el sitio ... y dado que los usuarios están en Netscape, Firefox sería una ruta muy compatible para actualizar ya que los conceptos y el diseño son muy similares (por ejemplo, marcadores, opciones de menú contextual, etc.)

Por lo tanto, proporcionar un enlace de descarga para Firefox 3 proporcionaría a los usuarios una ruta guiada sin problemas para actualizar.

Tal vez sólo un simple iframe conesta funcionaria bien

Preguntas relacionadas