Pregunta sobre box-api – ¿Cuándo dejará de funcionar la caja v1 api?

3

Estoy tratando de determinar qué versión de la API de Box debería usar. Mi decisión depende de la línea de tiempo de EOL de v1 api. No quiero terminar mi aplicación, y justo antes (o poco después) del lanzamiento de la aplicación, la API v1 deja de funcionar.

Me encantaría usar el v2 api, pero estoy escribiendo una aplicación de C #. Dado que hay un C # SDK para la api v1, sería más conveniente (a corto plazo) utilizar v1 de la api; pero como dije, estoy preocupado por la EOL de la v1 api.

Me doy cuenta de eso, Filburt, pero no hay información en el sitio de Box sobre este tema específico. Los foros en Box apuntan a StackOverflow. Vance-Turner

Tu respuesta

1   la respuesta
7

API v2 se puso a disposición general (GA) un año antes de eso y se lanzó en Beta en marzo de 2012.

Hemos ampliado nuestro soporte para todas las aplicaciones de uso activo creadas en la API v1 durante 3 meses adicionales, después de lo cual el soporte de la API v1 se ha eliminado.

La API v2 ahora está bien probada, tiene aproximadamente 3 veces el rendimiento, así como un 10% -20% más de superficie que expone para su uso.

Gracias por la respuesta detallada. Vance-Turner
La API de V1 fue oficialmente obsoleta el 15 de diciembre de 2013. La documentación sobre cómo migrar se publicó a principios de 2013 y se actualizó hasta octubre de 2013. Peter

Preguntas relacionadas