Pytanie w sprawie javascript, conflict, browser, netscape, jquery – Uzyskanie jQuery do pracy z Netscape 7 i 8

0

Netscape nie potrafi odczytać wielu napisanych jQuery. Jakie kroki podejmujesz, aby je przezwyciężyć i jak dużą część rynku wykorzystują użytkownicy netscape?

Czy masz jakieś dane, które wskazują, że twoi odbiorcy korzystają z Netscape 7 i 8? Jeśli nie, nie przejmuj się tymi dwoma. montrealist

Twoja odpowiedź

3   odpowiedź
0

nie jest już utrzymywany (R.I.P)

Tak samo jak wszyscy jestem za mantrą „wspieraj wszystkie przeglądarki” - wspieranie użytkowników „martwej” technologii wydaje się dużym zadaniem.

IIRC, theMacierz wsparcia jQuery opiera się na wspieraniu najnowszej obsługiwanej głównej wersji głównej przeglądarki (i poprzedniej 1 poziomu).Netscape 7 i 8 są wyłączone z tej listy.

Sugerowałbym proste powiadomienie „Upgrade” dla strony ... a ponieważ użytkownicy są w Netscape, Firefox byłby bardzo kompatybilną ścieżką do uaktualnienia, ponieważ koncepcje i układ są bardzo podobne (np. Zakładki, opcje menu kontekstowego, itp.)

Udostępnienie łącza pobierania dla Firefoksa 3 zapewni użytkownikom płynną ścieżkę do aktualizacji.

Może po prostu prosty iframe zto będzie dobrze działać.

0

Powiedziawszy to, muszę przyznać, że jquery zawodzi na wielu stronach podczas działania prototypu, w moim starożytnym Konquerorze 3.5.10, więc może jest tu jakiś wzór.

5

Niech to zawiedziePoczekaj, aż użytkownicy Netscape zauważą, że używają długiej martwej przeglądarki z lukami w zabezpieczeniach

Udział rynkowy Netscape jest tak bliski zeru, jak to jest bez znaczenia.

Powiązane pytania