Pytanie w sprawie box-api – Kiedy przestanie działać api Box v1?

3

Próbuję ustalić, która wersja Boxa api powinna być używana. Moja decyzja zależy od osi czasu EOL api v1. Nie chcę kończyć mojej aplikacji, a tuż przed (lub wkrótce po) wydaniem aplikacji, api v1 kończy pracę.

Chętnie skorzystałbym z api v2, ale piszę aplikację C #. Ponieważ istnieje pakiet C # SDK dla api v1, wygodniejsze (w krótkim okresie) byłoby użycie v1 api; ale jak powiedziałem, obawiam się EOL api v1.

Zdaję sobie sprawę, że Filburt, ale nie ma żadnych informacji na stronie Box dotyczących tej konkretnej kwestii. Fora w Box wskazują na StackOverflow. Vance-Turner

Twoja odpowiedź

1   odpowiedź
7

Rozpoczęliśmy proces deprecjonowania API v1 w grudniu 2013 r. API v2 stało się ogólnie dostępne (GA) rok wcześniej i zostało wydane w wersji beta w marcu 2012 r.

Rozszerzyliśmy nasze wsparcie dla wszystkich aktywnie używanych aplikacji zbudowanych na interfejsie API v1 przez dodatkowe 3 miesiące, po czym wycofano obsługę API v1.

API v2 jest teraz dobrze sprawdzone, ma około 3 razy większą wydajność, a także 10% -20% więcej powierzchni, którą eksponuje do użytku.

V1 API oficjalnie został unieważniony 15 grudnia 2013 r. Dokumentacja dotycząca migracji została opublikowana na początku 2013 r. I zaktualizowana do października 2013 r. Peter
Dziękujemy za szczegółową odpowiedź. Vance-Turner

Powiązane pytania