Pergunta sobre browser, jquery, netscape, conflict, javascript – Obtendo o jQuery para trabalhar com o Netscape 7 e 8

0

O Netscape não consegue ler muitos jQuery escritos. Que medidas você toma para superá-las e quanto do mercado os usuários do netscape adotam?

Você tem algum dado que indique que o público do seu site usa o Netscape 7 & 8? Se não, não se incomode com esses dois. montrealist

Sua resposta

3   a resposta
0

Tendo dito isso, tenho que admitir que o jquery falha em muitos sites enquanto o protótipo funciona, no meu antigo Konqueror 3.5.10, então talvez haja um padrão aqui.

5

Deixe falharAguarde até que os usuários do Netscape percebam que estão usando um navegador muito antigo com falhas de segurança

A participação de mercado da Netscape é tão próxima de zero quanto qualquer outra.

0

não é mais mantido (R.I.P)

Assim, tanto quanto eu sou todo para o mantra "suporte a todos os navegadores" - suportar usuários de uma tecnologia agora "morta" parece ser uma tarefa difícil.

IIRC, omatriz de suporte jQuery baseia-se no suporte à versão principal mais recente de um navegador principal (e 1 nível anterior).Netscape 7 e 8 são excluídos desta lista.

Eu sugeriria um simples aviso "Por favor, atualize" para o site ... e como os usuários estão no Netscape, o Firefox seria um caminho muito compatível para atualizar já que os conceitos e layout são muito semelhantes (por exemplo, favoritos, opções de menu de contexto, etc)

Assim, fornecer um link de download para o Firefox 3 forneceria aos usuários um caminho orientado para a atualização.

Talvez apenas um simples iframe comisto funcionaria bem.

Perguntas relacionadas