Вопрос по ubuntu, ubuntu-12.04, nokogiri, ruby – Что такое надежный процесс установки Nokogiri (в Ubuntu)?

7

Я попытался установить Nokogiri в моей системе Ubuntu 12.04 и получил сообщение об ошибке & quot;libxslt is missing& quot ;, ноlibxslt-dev а такжеlibxml2-dev установлены.

Есть ли надежный процесс установки? Как я могу проверить ссылки на зависимые библиотеки?

Я использовал RVM, и RVM pkg тоже установлен.

ERROR:  Error installing nokogiri:
    ERROR: Failed to build gem native extension.

        /home/victor/.rvm/rubies/ruby-1.9.3-p125/bin/ruby extconf.rb
checking for libxml/parser.h... yes
checking for libxslt/xslt.h... yes
checking for libexslt/exslt.h... yes
checking for iconv_open() in iconv.h... yes
checking for xmlParseDoc() in -lxml2... yes
checking for xsltParseStylesheetDoc() in -lxslt... no
-----
libxslt is missing.  please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
-----
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
    --with-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/home/victor/.rvm/rubies/ruby-1.9.3-p125/bin/ruby
    --with-zlib-dir
    --without-zlib-dir
    --with-zlib-include
    --without-zlib-include=${zlib-dir}/include
    --with-zlib-lib
    --without-zlib-lib=${zlib-dir}/lib
    --with-iconv-dir
    --without-iconv-dir
    --with-iconv-include
    --without-iconv-include=${iconv-dir}/include
    --with-iconv-lib
    --without-iconv-lib=${iconv-dir}/lib
    --with-xml2-dir
    --without-xml2-dir
    --with-xml2-include
    --without-xml2-include=${xml2-dir}/include
    --with-xml2-lib
    --without-xml2-lib=${xml2-dir}/lib
    --with-xslt-dir
    --without-xslt-dir
    --with-xslt-include
    --without-xslt-include=${xslt-dir}/include
    --with-xslt-lib
    --without-xslt-lib=${xslt-dir}/lib
    --with-libxslt-config
    --without-libxslt-config
    --with-pkg-config
    --without-pkg-config
    --with-libxml-2.0-config
    --without-libxml-2.0-config
    --with-libiconv-config
    --without-libiconv-config
    --with-xml2lib
    --without-xml2lib
    --with-xsltlib
    --without-xsltlib


Gem files will remain installed in /home/victor/.rvm/gems/[email protected]/gems/nokogiri-1.5.4 for inspection.
Results logged to /home/victor/.rvm/gems/[email protected]/gems/nokogiri-1.5.4/ext/nokogiri/gem_make.out
    enter code here
попробуйте установитьlibxml2 libxml2-dev libxslt1-dev? Brandon Kreisel
ВанДарг, а как насчет пути? Reader
Пожалуйста, отправьте по электронной почте список рассылки nokogiri-talk с содержимым вашего файла mkmf.log после неудачной установки. Mike Dalessio
Брэндон Крейзель, эти либы установлены. Reader
Еслиlibxslt Установлены библиотеки, вы, вероятно, должны указать путь. Chris Dargis

Ваш Ответ

5   ответов
0

Я перепробовал все, что вы найдете в Интернете. Убедитесь в наличии пакетов, перечисленных на странице установки Nokogiri, и т. Д.

Единственное, что в конечном итоге сделало это для меня, это установка libsxlt из исходного кода. После этого все заработало отлично.

7

хотя я сделал следующее в соответствии с документацией:

sudo apt-get install libxslt-dev libxml2-dev rvm pkg libxml2 and rvm pkg libxslt

Единственный способ, которым я мог решить эту проблему, был после продолжительного расследования:

Uninstall the ruby installation: rvm remove 1.9.3 Delete all libxslt* and libxml2* libs from ~/.rvm/usr/lib if you had previously done rvm pkg ... Reinstall ruby: rvm install 1.9.3

Переустановкаafter apt-get команды, кажется, единственный способ заставить это работать. Кроме того, обеспечение библиотек, установленных сrvm pkg не мешайте помогать.

When everything else fails...

Если все остальное терпит неудачу, и вам абсолютно необходим установленный гем, вы также можете восстановитьnokogiri путем применения простого патча & # x2014; & # xA0; при условии, что у вас установлены все инструменты сборки, и с оговоркой, что это установит самый последний и потенциально нестабильный код:

git clone git://github.com/sparklemotion/nokogiri get patch from this gist and save it as x86_64.patch in the nokogiri folder. Apply patch: patch -p1 < x86_64.patch Rebuild: rake native gem — this should build the gem in the pkg/ folder Install the gem using gem install pkg/nokogiri-<version>-x86_64-linux.gem
Это фактически помогло мне устранить ошибку при установке chef через gem в Ubuntu 12.04 с использованием только пакетов - я не хотел использовать RVM, так как для этого блока требуется всего 1.9.3 для всей системы. Спасибо!
0

gem install nokogiri -v '1.5.2' -- --with-xml2-lib=/usr/lib/i386-linux-gnu --with-xml2-include=/usr/include/libxml2 --with-xslt-lib=/usr/lib/i386-linux-gnu --with-xslt-include=/usr/include/libxslt

... работал для меня на Ubuntu 12.04. (Или, во всяком случае, это удовлетворило зависимость от nokogiri и сделало меня на один шаг ближе к тому, чего я действительно пытаюсь достичь.) Я думал, что это могло испортить мою магию RVM, но nokogirl-1.5.2 определенно сидит там в ~ /.rvm/ruby-1.9.3-p194/gems, так что ... может быть, все хорошо?

как правило, с такими неконкретными вопросами, как этот, он помогает спрашивающему (и будущим поисковикам) предоставлять надежные решения, не зависящие от системы / настройки, или инструктировать о том, как анализировать и исправлять определенную часть процесса, которая может вызвать ошибки (библиотека связи, например)
0

/ usr / lib / ruby / 1.9.1 / x86_64-linux

-1
sudo apt-get install ruby1.8-dev ruby1.8 ri1.8 rdoc1.8 irb1.8
sudo apt-get install libreadline-ruby1.8 libruby1.8 libopenssl-ruby
sudo apt-get install libxslt-dev libxml2-dev

Я уже установил все и все еще получаю ту же ошибку Reader

Похожие вопросы