Вопрос по ruby-on-rails, passenger, ruby-on-rails-2, macos, pcre – Как установить заголовки для разработки PCRE на Mac OSX

13

Я только что обновил свой MacBook Pro до Mavericks, и моя локальная среда разработки Ruby on Rails некогда я навещаюlocalhost я вижуIt works! и вспомнил, что мне нужно запустить Phusion Passenger, поэтому, когда я бегуpassenger start он проверяет все предварительные условия и дает сбой, когда попадает в заголовки разработки PCRE:

 * Checking for PCRE development headers...
    Found: no

Это говорит мне, чтобы пойти вhttp://www.pcre.org/ чтобы скачать их, поэтому я скачал 8,33 изВот который пошел к моемуDownloads папку, поэтому я распаковал ееcdд в папку и побежал:

./configure
make
make install

Затем 'cdвернуться в каталог приложений rails на рабочем столе и перезапуститьpassenger start но это'все то же самое. Попробовал новое окно терминала, но это нене имеет значения.

Я должен был сделать это раньше, чтобы моя среда разработки работала, но могуКажется, на этот раз это решить.

Я тоже пробовалbrew install pcre но это говорит.Warning: pcre-8.33 already installed

brew install pcre: у меня сработало RajG
brew install pcre - у меня тоже сработало knx

Ваш Ответ

2   ответа
14

Переустановите OS X Developer Tools. Это было сломано обновлением Mavericks.

выполнив xcode-select --install Rene van Lieshout
Это работает? Я нуждался в .brew install pcre orome
15

Переустановка OS X Developer Tools не работает для меня, поэтому я рекомендую

brew install pcre

Также вы можете сделать

brew install passenger

Который установит все необходимые требования, если дополнительные отсутствуют.

brew install pcre работал на меня. user664833
Спасибо чувак. Ты замечательный. Yevhenii Kanivets

Похожие вопросы