Вопрос по unsatisfiedlinkerror, eclipse, ubuntu, java – Eclipse не может загрузить библиотеки SWT

287

Каждый раз, когда я пытаюсь открыть Eclipse в Ubuntu 12.04, я получаю сообщение об ошибке Unsatisfied Link, и оно не открывается. Я недавно установил java JDK и Android SDK, может ли это быть проблемой? Я последовал заэтот урок.

Вот информация журнала:

<code>!SESSION 2012-04-15 21:05:46.902 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.7.0
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-04-15 21:05:47.885
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
no swt-gtk-3740 in java.library.path
no swt-gtk in java.library.path
Can't load library: /home/tom/.swt/lib/linux/x86_64/libswt-gtk-3740.so
Can't load library: /home/tom/.swt/lib/linux/x86_64/libswt-gtk.so

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
at org.eclipse.swt.internal.C.<clinit>(C.java:21)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
</code>

Я попытался удалить и переустановить, а также удаление~/.eclipse каталог, но он все еще не работает

Вы установили libswt-java-gtk3? Federico Vera
Несмотря на то, что на этот ответ дан ответ ниже, похоже, что это остается ошибкой в системе установки Ubuntu, которую следует устранить, потому что она сохраняется, даже если я удаляю и переустанавливаю eclipse с помощью aptitude / apt-get. Если есть ссылка на этот вопрос, было бы неплохо указать ее здесь, чтобы люди могли ее проголосовать. android.weasel
Я должен сказать, что ваш путь к библиотеке выглядит странно. Разве эти файлы .so не должны находиться где-нибудь в папке eclipse / plugins, внутри разобранного jar-файла? У вас даже есть такой каталог (~ / .swt / lib / ...)? Marko Topolnik

Ваш Ответ

12   ответов
12

/usr/lib/jni каталог целиком. Исправлено

sudo apt-get install libswt-gtk-3-jni libswt-gtk-3-java

Не нужно символическую ссылку потом. Затмение началось нормально.

После установки JNI. Я скопировал файлы, используя эту команду для 32-битной: ln -s / usr / lib / jni / libswt- * ~ / .swt / lib / linux / x86 /
4
Can't load library: /home/tom/.swt/lib/linux/x86_64/libswt-gtk-3740.so
Can't load library: /home/tom/.swt/lib/linux/x86_64/libswt-gtk.so

что библиотеки должны быть в .swt / lib / linux / x86_64 /, если их там нет, вы можете попробуйте эту команду:

locate  libswt-gtk.so

это должно найти библиотеки скопировать весь каталог в /home/tom/.swt/lib/linux/x86_64

я сталкиваюсь с подобной ошибкой в Linux 64 бит, вы можете проверить этот вопрос,stackoverflow.com/questions/21980558/…
0

убедитесь, что ваш домашний раздел смонтирован с исполняемыми разрешениями. Это значение по умолчанию, но если вы подключите его без опции exec, вы получите эту ошибку.

1

На redhat7:

yum install gtk2 libXtst xorg-x11-fonts-Type1

сделал работу, из-за зависимости SWT.

найденныйВот

52

Поскольку я установил Oracle Java 7, он заменил Java по умолчанию на Oracle Java 7, однако это должен был быть Open JDK.

Чтобы исправить, откройте терминал и введите

sudo update-alternatives --config java

Это поднимает список различных типов Java. Просто выберите Open JDK.

это потому, что Oracle Java 7 больше не ищет нативную библиотеку в Jars? У меня та же проблема на окнах с Java 7, а также. программа SWT раньше работала очень хорошо
Работал для меня на Linux Mint Maya.
Конечно, если вы предпочитаете FOSS, OpenJDK является предпочтительной платформой, но (как обычно с этими корпоративными троглодитами) Oracle налагает определенные хуки в своей версии, которые предотвращают перенос некоторых приложений (и большинства приложений Java-запуска) между платформами Java. Это побеждает основную цель Java, а именно переносимость, именно поэтому они стреляют себе в ногу, практикуя блокировку вендора ... Да здравствует Python! Да здравствует!
был решением для меня, но это скорее обходной путь ..
но что, если вы хотите использовать Oracle Java с затмением, а не Open JDK, как можно это сделать? Спасибо!
2

используя oracle java, то eclipse может не найти собственные библиотеки, такие как библиотеки SWT или SVN. Библиотеки SWT-JNI находятся в / usr / lib / jni /, а библиотеки SVN-JNI находятся в / usr / lib / x86_64-linux-gnu / jni /.

Вместо запуска затмения с помощью команды

eclipse

вы можете использовать команду

env LD_LIBRARY_PATH=/usr/lib/jni/:/usr/lib/x86_64-linux-gnu/jni/:$LD_LIBRARY_PATH eclipse

передать переменную окружения LD_LIBRARY_PATH для затмения. Eclipse найдет собственные библиотеки и будет работать правильно.

0

Возможно, более общий метод заключается в следующем:

  • install non-headless version of the openjdk,
  • install, run and close eclipse.
  • uninstall the openjdk
  • install oracle's JDK
42

echo "-Djava.library.path=/usr/lib/jni/" >> /etc/eclipse.ini
Я действительно работал над 64-битным решением Ubuntu Cleanest, я рекомендую любому выбрать это решение вместо создания символических ссылок.
Согласитесь, очистите, и этот метод навсегда предотвратит ошибку в системе Ubuntu, которая соответствует изменениям версии Java - учитывая побочный эффект обновлений OpenJDK для перенастройки расположения файлов, связанных с Java.
Ответ с наибольшим количеством голосов работает, но не для случая, когда вы «sudo eclipse». Этот ответ выше, он работает во всех случаях!
это тот, который нужно использовать, если вы используете oracle java 7 и не открываете JDK
Кажется, это самое чистое решение.
1

когда пытался запустить 32-битную сборку Eclipse под 64-битным Linux. Проблема была решена после установки пакета ia32-libs.

660

32 bit, Я редактирую команду, чтобы:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/

И на Ubuntu 12.0464 bit пытаться:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/
Это реальный спасатель жизни! Обратите внимание, что любой, кто использует ARM (например, я использую Eclipse на Chromebook), должен заменить & quot; x86 & quot; с "рукой" в противном случае это не сработает!
Спасибо. Мой путь был немного другим, но это исправило это для меня.ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/
Я предпочитаю этот метод, так как я должен использовать Oracle Java 7 для проекта
Я выполнил эту команду именно так, как она у вас, и она сработала! Ubuntu 12.04 с Oracle Java 7
Это второй раз, когда мне приходилось делать это: один раз на моем рабочем компьютере несколько месяцев назад и только сейчас на моем домашнем компьютере, оба раза после нескольких месяцев использования Eclipse без единой проблемы. Есть ли какие-то конкретные причины, по которым библиотеки SWT просто исчезают?
0

из-за этого я получаю ошибки. После установки JDK 64 битhttp://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html jdk-8u131-linux-x64.tar.gz (пожалуйста, загрузите 64-версию) и загрузите 64-битную версию eclipse-inst-linux64.tar.gz.

3

что он перечислил работал. Однако просто запустить его из любого каталога не сработало. Я должен был CD в / домой /*/.swt/lib/linux/x86_64/ 0 файлов

сначала каталог, а затем запустите команду ссылки:

Для 32 бит:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/

А на Ubuntu 12.04 64 bit:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/

Похожие вопросы