Вопрос по android-activity, eclipse, android – Eclipse Juno не будет создавать Android Activity

11

Я загрузилEclipse Juno Java EE edition и установленADT plugin, Я создал новыйAndroid Application Проект отEclipse и в мастере я создал действие под названием TaskariActivity. После того, как я нажал кнопку "Готово", он создал проект, но не действие, и мастер не закрылся. Я нажал "Отмена". Нет активности или что-либо в папке src. Я создал новое действие, щелкнув правой кнопкой мыши на src, выбравnew -> other -> Android -> activity, Я выбрал BlankActivity (как и раньше, когда создавал проект), выбрал ранее созданный проект в поле со списком Project. Я установилActivity имя как TaskariActivity, имя макета как Activity_main и заголовок как TaskariActivity. Затем я выбрал тип навигации и установил егоTabs + Swipe (Я думал, что это сделает меня вкладками, и все, что мне нужно было сделать, это просто вставить элементы и действия для них). Я нажал затем, ничего не произошло. Finish также ничего не делал. Я нажал "Отмена", и действие не было создано.

Итак, как я могу создатьAndroid application как в более ранней версииEclipse? Это автоматически создало действие, и это было готово быть запущенным из коробки. Теперь он не будет генерировать какие-либо файлы, а мастер новой активности не работает. Помогите?

У меня такая же проблема с Eclipse 3.7. Если я создаю проект без действия, он работает, но в папках src или layout нет файлов (мало пользы!). Если я выбираю Blank Activity, то мастер говорит мне, что мне нужна библиотека поддержки версии 8. У меня уже есть версия 9. Полностью застрял сейчас NickT
Имея ту же проблему, я не получаю никаких сообщений об ошибках, диалог активности просто остается. Запись для нового действия создается в манифесте, но метка не добавляется в strings.xml, и в папке src не создается никаких действий. Я попытался обновить библиотеку поддержки, менеджер SDK и сам Eclipse. Я перезапустил Eclipse и все еще ничего. Странно то, что я могу сделать это для некоторых проектов, но не для других .. user1088166
проверьте мой отредактированный ответ rajpara

Ваш Ответ

5   ответов
4

Справка & quot; - & GT; & quot; Установить новое программное обеспечение & quot; и установите (это обновит его) с этого URL:https://dl-ssl.google.com/android/eclipse/ Я полагаю, что на сайте Android нет обновленной версии ADT? Не уверен, где вы должны загрузить последнюю версию с

Да! У меня 22,3, установить 22,6, как вы описываете - все хорошо !!!
3

который мне помог (если вы установили библиотеку поддержки & gt; 8 и по-прежнему получаете сообщение об ошибке)

Delete the support library from the SDK manager Create a new project & install the support library by clicking on "Install / Upgrade"

Проверьте этот ответ.

Это даст мне полностью пустой проект, без исходных текстов или xml. Не совсем решение.
Не повезло с этим. Не работал: / MikkoP
Да, я перезапустил IDE. Не работает. MikkoP
Отредактированная версия также не помогла. Кстати, проводник проекта выглядит очень странно.img832.imageshack.us/img832/1194/taskaritietokanta.png MikkoP
Вы перезапустили затмение, кстати, проверьте этоcode.google.com/p/android/issues/detail?id=33859 это также упомянуть то же самое
6

о того, чтобы настраивать его, и оно должно работать;)

спасибо, это решило проблему для меня
На самом деле не имеет отношения к новому мастеру действий в существующем проекте Android, так что это не совсем решение
Очень странно ... но это сработало. Спасибо! MikkoP
0

и я смог создать проект, изменив "минимально необходимый SDK". до 3,0 сот.

Какую версию вы выбрали?

1

обновив библиотеку поддержки (с помощью диспетчера SDK Android, она находится в конце списка в разделе «Дополнительная информация», «Поддержка Android», «Библиотека») с версии 8 до версии 9!

 После обновления Eclipse теперь может создавать проекты, как и ожидалось.

Я думаю, что решение просто связано с обновлением вашей текущей версии, какой бы она ни была (у меня было 8), до последней (которая является 9-й версией). Дело в том, что, очевидно, проекты теперь создаются с включенной библиотекой поддержки, когда вы устанавливаете более низкую версию минимальной sdk, например, 2.2, но правильно включена только последняя библиотека поддержки. Если у вас нет rev9, я буду использовать d. попробуйте установить его и посмотреть, как он идет, если вы уже это сделали, то, извините, возможно, что-то еще.
Может работать, но у меня нет версии 8 на моем ПК. MikkoP

Похожие вопросы