Вопрос по java, hibernate – Ошибка: устарел PersistenceProvider, используйте HibernatePersistenceProvider вместо HibernatePersistence

11

Я думаю, что это очень распространенная проблема для всех начинающих, как я. Но я не мог найти решение. Еще.

Файл persistence.xml находится в src / META-INF / persistence.xml

<?xml version="1.0" encoding="UTF-8"?>
    <persistence xmlns="http://java.sun.com/xml/ns/persistence"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/persistence
    http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd"
    version="2.0">

    <persistence-unit name="jobs">

    <!-- provedor/implementacao do JPA -->
    <provider>org.hibernate.ejb.HibernatePersistenceProvider</provider>

    <!-- entidade mapeada -->
    <class>
        br.com.caelum.tarefas.modelo.Job
    </class>

    <properties>
        <!-- dados da conexao -->
        <property name="javax.persistence.jdbc.driver" value="com.mysql.jdbc.Driver" />
        <property name="javax.persistence.jdbc.url" value="jdbc:mysql://localhost/fj21" />
        <property name="javax.persistence.jdbc.user" value="root" />
        <property name="javax.persistence.jdbc.password" value="root" />

        <!-- propriedades do hibernate -->
        <property name="hibernate.dialect" value="org.hibernate.dialect.MySQL5InnoDBDialect" />
        <property name="hibernate.show_sql" value="true" />
        <property name="hibernate.format_sql" value="true" />

        <!-- atualiza o banco, gera as tabelas se for preciso -->
        <property name="hibernate.hbm2ddl.auto" value="update" />

    </properties>
</persistence-unit>

Когда я запускаю код

try
{
    EntityManagerFactory factory = Persistence.createEntityManagerFactory("tarefas");
    EntityManager manager = factory.createEntityManager();

    manager.close();
    factory.close();
    System.out.println("Execução com sucesso!");
}catch(Exception _Ex)
{
    System.out.println("Erro: " + _Ex.getMessage());
}

Я получаю сообщение

27/03/2014 11:35:18 org.hibernate.ejb.HibernatePersistence logDeprecation WARN: HHH015016: Encountered a deprecated javax.persistence.spi.PersistenceProvider [org.hibernate.ejb.HibernatePersistence]; use [org.hibernate.jpa.HibernatePersistenceProvider] instead.
27/03/2014 11:35:18 org.hibernate.ejb.HibernatePersistence logDeprecation WARN: HHH015016: Encountered a deprecated javax.persistence.spi.PersistenceProvider [org.hibernate.ejb.HibernatePersistence]; use [org.hibernate.jpa.HibernatePersistenceProvider] instead.
27/03/2014 11:35:18 org.hibernate.ejb.HibernatePersistence logDeprecation WARN: HHH015016: Encountered a deprecated javax.persistence.spi.PersistenceProvider [org.hibernate.ejb.HibernatePersistence]; use [org.hibernate.jpa.HibernatePersistenceProvider] instead.
Erro: No Persistence provider for EntityManager named jobs

Что я делаю не так?

Макотон я исправил но все равно не работает. user3411221
Я думаю, что вы <persistence-unit name = "jobs"> должны быть такими же с Persistence.createEntityManagerFactory ("jobs"); оно работает? Makoton
добавьте эту зависимость вашим менеджером зависимостей <dependency> <groupId> org.hibernate </ groupId> <artifactId> hibernate-entitymanager </ artifactId> <version> $ {hibernate-core-version} </ version> </ dependency> ваша текущая версия Makoton

Ваш Ответ

2   ответа
16

aurelije является правильным, однако ошибка в Hibernate будет неправильно сообщать о проблеме, даже если вы указали правильныйHibernatePersistenceProvider: все подробности об ошибке можно найти вотчет об ошибке HHH-9141 и существуют в Hibernate EntityManager версии 4.3.5. Наконец.

28

Проблема в этой строке из файла persistence.xml:

<!-- provedor/implementacao do JPA -->
<provider>org.hibernate.ejb.HibernatePersistenceProvider</provider>

Это должно быть изменено на

<!-- provedor/implementacao do JPA -->
<provider>org.hibernate.jpa.HibernatePersistenceProvider</provider>

Даже если в файле persistence.xml отсутствует тег поставщика, из-за ошибки Hibernate Hibernate будет использовать реализацию старого поставщика ejb, а затем будет жаловаться на это (шизофрения)

Для таких как я, которые не заметили это на глаз: .ejb. -> .jpa. Pieter De Bie
Когда я меняю своего провайдера на «org.hibernate.jpa.HibernatePersistenceProvider», я получаю «javax.ejb.EJBException: java.lang.NullPointerException». При использовании старого провайдера все работает нормально ... (JBoss EAP 6.1). У кого-нибудь еще есть такая проблема? Sverro2

Похожие вопросы