Вопрос по node.js, ubuntu – Установка Nodejs и Coffeescript (Ubuntu 12.04)

2

Edit: I have added an answer on how to fix this in case someone struggles with it.

Я обновил свой ноутбук с Ubuntu 11 до 12.04, и по какой-то причине перестал работать компилятор coffeescript. Я использую его для веб-разработки, но я все еще новичок, работающий в среде Linux.

В основном, когда я пытаюсь запустить cake.coffeescript, я получаю следующее:

path.existsSync is deprecated. It is now called `fs.existsSync`.
Cakefile defines the following tasks:

cake doc                  # generate documentation for *.coffee files
cake doc_copy             # copy documentation to gh-pages branch
cake build                # generate unified JavaScript file for whole Hallo
cake min                  # minify the generated JavaScript file
cake bam                  # build and minify Hallo

Так что в некотором смысле это работает, но всякий раз, когда я пытаюсь запустить build.coffeescript, он выдает ошибку:

path.existsSync is deprecated. It is now called `fs.existsSync`.
Executing coffee -o examples -j hallo.js -c `find src -type f -name '*.coffee'`
{ [Error: Command failed: 
node.js:249
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
    at Function.<anonymous> (module.js:381:11)
    at Object.<anonymous> (/home/ignas/bin/[email protected]:4:21)
    at Module._compile (module.js:444:26)
    at Object..js (module.js:462:10)
    at Module.load (module.js:351:32)
    at Function._load (module.js:309:12)
    at module.js:482:10
    at EventEmitter._tickCallback (node.js:238:11)
] killed: false, code: 1, signal: null }

node.js:249
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
    at Function.<anonymous> (module.js:381:11)
    at Object.<anonymous> (/home/ignas/bin/[email protected]:4:21)
    at Module._compile (module.js:444:26)
    at Object..js (module.js:462:10)
    at Module.load (module.js:351:32)
    at Function._load (module.js:309:12)
    at module.js:482:10
    at EventEmitter._tickCallback (node.js:238:11)

Я думаю, это вызвано nodejs. Я пытался найти решение, но ничего не помогло. Я думаю, что проблема связана с переменной NODE_PATH, которую я включил в начало файла ~ / .bashrc (я следовалэтот учебник по установке всего). Любая помощь будет принята с благодарностью, потому что я собираюсь закончить часть проекта и должен передать ее, но не могу сделать это без компиляции файлов сценария.

Спасибо

Или ответьте и примите ваш ответ на случай, если кто-то попадет в такую же проблему. mreq

Ваш Ответ

1   ответ
8

All sorted now.  а также все из репозиториев Ubuntu, содержащих npm, coffee-script и node, и установить все из git. Пошаговая установка:

1. clone https://github.com/joyent/node.git
2. git checkout v0.6.17 //current stable at my time
3. cd node && ./configure && make && make install
4. curl http://npmjs.org/install.sh | sudo sh
5. download coffeescript from git and do sudo bin/cake install
6. sudo npm install coffee-script -g

Это должно работать

Похожие вопросы