Вопрос по ruby, macos – Возникли проблемы при установке любого ruby 1.9.x (с rbenv) на Mac OSX из-за психических ошибок синтаксического анализа YAML

1

Я попытался удалить rvm, чтобы использовать rbenv на моем Mac. Все работает нормально, пока рубин не вступит в игру ..

когда используешь

rbenv install 1.9.3-p194

он компилируется правильно, но после этого я хотел бы установить упаковщик ... это выдает следующую ошибку

computer:~ computer$ gem install bundler
/Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/psych.rb:203:in `parse': (<unknown>): mapping values are not allowed in this context at line 1 column 34 (Psych::SyntaxError)
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/psych.rb:203:in `parse_stream'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/psych.rb:151:in `parse'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/psych.rb:127:in `load'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/rubygems/config_file.rb:253:in `load_file'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/rubygems/config_file.rb:191:in `initialize'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/rubygems/gem_runner.rb:78:in `new'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/rubygems/gem_runner.rb:78:in `do_configuration'
    from /Users/computer/.rbenv/versions/1.9.3-p194/lib/ruby/1.9.1/rubygems/gem_runner.rb:51:in `run'
    from /Users/computer/.rbenv/versions/1.9.3-p194/bin/gem:21:in `<main>'

Затем я попытался установить более старую версию ruby 1.9.3-p125 ... но тогда даже сборка не завершится с похожей ошибкой, которая также зависит от этого психического интерпретатора ... :(

computer-2:~ computer$ rbenv install 1.9.3-p125
Downloading http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz...
Installing yaml-0.1.4...
Installed yaml-0.1.4 to /Users/computer/.rbenv/versions/1.9.3-p125
Downloading http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p125.tar.gz...
Installing ruby-1.9.3-p125...
Installed ruby-1.9.3-p125 to /Users/computer/.rbenv/versions/1.9.3-p125
Downloading http://production.cf.rubygems.org/rubygems/rubygems-1.8.23.tgz...
Installing rubygems-1.8.23...

BUILD FAILED

Inspect or clean up the working tree at /var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105
Results logged to /var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105.log

Last 10 log lines:
/Users/computer/.rbenv/versions/1.9.3-p125/lib/ruby/1.9.1/psych.rb:154:in `parse': (<unknown>): couldn't parse YAML at line 0 column 33 (Psych::SyntaxError)
    from /Users/computer/.rbenv/versions/1.9.3-p125/lib/ruby/1.9.1/psych.rb:154:in `parse_stream'
    from /Users/computer/.rbenv/versions/1.9.3-p125/lib/ruby/1.9.1/psych.rb:125:in `parse'
    from /Users/computer/.rbenv/versions/1.9.3-p125/lib/ruby/1.9.1/psych.rb:112:in `load'
    from /private/var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105/rubygems-1.8.23/lib/rubygems/config_file.rb:253:in `load_file'
    from /private/var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105/rubygems-1.8.23/lib/rubygems/config_file.rb:191:in `initialize'
    from /private/var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105/rubygems-1.8.23/lib/rubygems/gem_runner.rb:78:in `new'
    from /private/var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105/rubygems-1.8.23/lib/rubygems/gem_runner.rb:78:in `do_configuration'
    from /private/var/folders/_9/tcqlf3c14l78vxtr600l9lqr0000gn/T/ruby-build.20120511162948.58105/rubygems-1.8.23/lib/rubygems/gem_runner.rb:51:in `run'
    from setup.rb:38:in `<main>'
computer-2:~ computer$ 

Я не смог найти в сети что-то такое же, что я спрашиваю ...

Я попробовал эти два ресурса, которые мне не помогли, как если бы установщик rbenv делал это автоматически

Установка libyaml для ruby на Mac OSX (Lion)

Исправление "установки ruby отсутствует psyche" ошибка?

У кого-нибудь есть предложение? Заранее спасибо..

Ваш Ответ

4   ответа
9

Error: User Rate Limit Exceeded

Error: User Rate Limit Exceeded

Error: User Rate Limit Exceeded pabera
Error: User Rate Limit Exceeded
1

Error: User Rate Limit Exceeded

install: --no-rdoc --no-ri
update: --no-rdoc --no-rigem: --no-document

Error: User Rate Limit Exceeded

install: --no-rdoc --no-ri
update: --no-rdoc --no-ri
5

Error: User Rate Limit Exceeded.gemrcError: User Rate Limit Exceeded.gemrcError: User Rate Limit Exceeded--Error: User Rate Limit Exceeded---Error: User Rate Limit Exceeded.gemrcError: User Rate Limit Exceeded

Error: User Rate Limit Exceeded.gemrc :

---
gem: --no-ri --no-rdoc

Error: User Rate Limit Exceeded
Error: User Rate Limit Exceeded
Error: User Rate Limit Exceeded
0
install: --no-rdoc --no-ri
update: --no-rdoc --no-rigem: --no-document

Error: User Rate Limit Exceeded

install: --no-rdoc --no-ri
update: --no-rdoc --no-ri
gem: --no-document

Error: User Rate Limit Exceeded

Похожие вопросы