Вопрос по rubygems, ruby-on-rails – Установка пакета не работает в автономном режиме

10

Я получил эту проблему. Я думаю, что установили упаковщик. И с тех пор я не могу связать установку при создании приложения в RoR или связать установку напрямую в рамках проекта. Пожалуйста, помогите мне, если у вас возникли проблемы и нашли решение для этого.

enter code here     :run  bundle install
:Fetching gem metadata from https://rubygems.org/.
:Error Bundler::HTTPError during request to dependency API
:Fetching full source index from https://rubygems.org/
:Could not reach https://rubygems.org/

Ваш Ответ

3   ответа
29

Если у вас установлены драгоценные камни, вы можете использоватьbundle install --local, Не требуется подключение к интернету

Спасибо Колфилд. Это действительно сработало. Большой!! Круто .. Я искал этот результат .. ROHITH KUMAR
+1 это должен быть принятый ответ
3

Следующий метод работает для меня.

$ rails new blog -B # -B tells rails not to run bundle install
cd blog
$ bundle install --local
Edit the GemFile and uncomment the line "therubyracer"
$ rails server
=> Booting WEBrick
=> Rails 4.0.0 application starting in development on http://0.0.0.0:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
[2013-09-28 19:09:35] INFO  WEBrick 1.3.1
[2013-09-28 19:09:35] INFO  ruby 2.0.0 (2013-05-14) [i686-linux]
[2013-09-28 19:09:35] INFO  WEBrick::HTTPServer#start: pid=1635 port=3000
2

Вам нужно будет быть в сети, чтобы упаковщик мог проверить с помощью rubygems, что у вас есть последние версии драгоценных камней, и при необходимости загрузить их.

Я был в состоянии связать установку, даже не будучи онлайн. ROHITH KUMAR
Привет, Он изначально работал в автономном режиме в Ubuntu. Я использую Aptana IDE, полагаю, я установил пакет или попытался настроить Spree CMS, поскольку автономная установка пакета не работает. Но теперь даже мои окна, Aptana IDE тоже получили ту же проблему. запустить пакет установить извлечение метаданных гема изrubygems.org, Ошибка Bundler :: HTTPError при запросе к API зависимости Выборка полного исходного индекса изrubygems.org Ошибка сети при полученииrubygems.org/quick/Marshal.4.8/sqlite3-1.3.6.gemspec.rz  Пожалуйста, помогите, если я сделал какую-либо ошибку ROHITH KUMAR

Похожие вопросы