Вопрос по windows-7, .net-3.5, visual-studio-2008, visual-studio-2010 – не могу установить .NET Framework 3.5

8

Я уже установил Microsoft Visual Studio 2008 SP1 и VS 2010 SP1. Я использую Windows 7.

Затем я заметил в своих Установленных программах на Панели управления, что только следующие компоненты были установлены .NET Framework:

Microsoft .NET Compact Framework 2.0 SP2 Microsoft .NET Compact Framework 3.5 Microsoft .NET Framework 4 Client Profile Microsoft .NET Framework 4 Extended.

По некоторым причинам, когда я устанавливал PowerCommands для Visual Studio 2008, он говорит, что мне нужно установить .NET Framework 3.5.

Когда я пытался использовать dotnetfx35.exe, он просто распаковывал установщик, но не продолжал процесс установки.

Это только потому, что я использую Windows 7? Или есть правильный способ настройки .NET Framework 3.5?

Спасибо!

Согласен. Но это странно. Если Windows 7 уже предустановлена, как я могу ее увидеть? Это в программах и функциях панели управления? Я установил проверочный тест .NET, и он говорит, что он прошел, однако я не могу полностью понять, как он может сказать, что он уже установлен. Какие-нибудь мысли? user1334004
Он предварительно установлен в Windows 7, он не появится в Установленных программах. Нажмите & quot; Включить или выключить функции Windows & quot; чтобы увидеть это. Ваша проблема с PowerCommands неопровержима. Hans Passant

Ваш Ответ

2   ответа
8

льзовать установочные файлы для .NET 3.5 framework. Кроме того, фреймворк 3.5 не обязательно отображается в программах добавления / удаления. Вместо этого вы "включаете" особенность Другая деталь заключается в том, что .NET 3.5 включает в себя фреймворки 3.0 и 2.0. Другими словами, .NET Framework 3.0 и 2.0 не требуют отдельной установки.

Чтобы «добавить» / проверить установку .NET 3.5 в Windows Server 2008 R2:

Go to Control Panel > Programs > Turn Windows Features on or off > Roles > Add Role Service (little button off to the right) > Ensure ".NET Framework 3.5.1" is checked > Click "next" until you can click "install".

Процесс должен быть похожим в Windows 7.

-1

что вы установили версию DOTNET 4.0 для некоторых приложений, вам нужен 3.5 .net framework.

Просто скачайте и установите DOT NET 3.5 SP1 (не только 3.5) отсюда1 здесь

(Примечание: см.Переполнение стека - .dot net framework Больше подробностей!)

Похожие вопросы