Лучшие gem вопросы ИТ разработчиков

  • 5 голосов
  • 6 ответов
  • 0 просмотров
6 ответов

проблема установки пакета с libv8 и рельсами

У меня проблемы сlibv8 гем с ruby 1.9.3p0 (2011-10-30 ревизия 33570) [x86_64-darwin10.8.0]. gem install libv8 работает нормально и у меня gem 'therubyracer'в моемGemfile и это зависит отlibv8 который устанавливается, когда я делаюbundle ...

Задан 27 Jan 2012, 18:39 от outside2344
  • 5 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

рельсы 4: значения сопоставления не разрешены в этом контексте в строке 2 столбца 11 (Psych :: SyntaxError)?

Я успешно установил rails 4 и создал проект, используя rails 4.0.0

Задан 08 Sep 2013, 14:01 от sivrj
  • 48 голосов
  • 6 ответов
  • 0 просмотров
6 ответов

Должно работать, если нет ошибки кодирования.

ользуюActiveAdmin [http://activeadmin.info/]жемчужина в моем проекте. У меня есть 2 модели, использующие has_many через ассоциацию. Схема базы данных выглядит точно так же, как в примере с ...

Задан 17 Aug 2011, 20:30 от Victor Lam
  • 3 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

ОШИБКА: ошибка установки json: ОШИБКА: не удалось создать собственное расширение gem

Я пытаюсь установить Gem JSON и получаю сообщение об ошибке для JSON.Я бегу:Windows 8.1 (64 бит)Ruby: ruby ​​1.9.3p545 (2014-02-24) [i386-mingw32]драгоценный...

Задан 30 Jun 2015, 12:41 от Kedar
  • 10 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Почему мастер foreman игнорирует переменную окружения PORT?

Я хочу, чтобы в мастере мастера использовалось значение PORT, указанное в файле env моей разработки, вместо использования его собственных значений. Настройка моих файлов показана ниже: Скрипт bash для запуска мастера: начальник бригады -e ...

Задан 21 Mar 2012, 11:58 от Tabrez
  • 73 голосов
  • 6 ответов
  • 0 просмотров
6 ответов

Установка Ruby Gem в Windows

Я новичок в рубине. Я попытался установить GEM на свой компьютер, выполнив действия, указанные на сайте.http://rubygems.org/pages/download [http://rubygems.org/pages/download] . Я скачал пакет с упомянутого сайта и изменил каталог на каталог, в ...

Задан 20 Sep 2013, 04:15 от user2797743
  • 5 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Как я могу сохранить весь пакет Rails App, включая используемые гемы?

Я использую много драгоценных камней. Они действительно чувствительны к зависимостям друг друга. Теперь текущая комбинация драгоценных камней просто идеальна. Я хочу сохранить все это приложение и использовать его снова, когда собираюсь перейти ...

Задан 26 Apr 2013, 02:15 от cat
  • 0 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Не удается установить JSON Gem в Windows

Я пытался установить JSON Gem на Windows. Я установил DevKit. Я получаю следующую ошибку ниже. Какие-либо предложения? Этот вопрос JSON Gem не будет установлен ...

Задан 17 Apr 2013, 22:11 от TinyGrasshopper
  • 19 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Неверный gemspec -Информированное требование [«# <YAML :: Syck :: DefaultKey: 0xb5f9c990> 3.2.0»]

Invalid gemspec in [/usr/lib/ruby/gems/1.8/specifications/activemodel-3.2.0.gemspec]: Illformed requirement ["#<YAML::Syck::DefaultKey:0xb5f9c990> 3.2.0"]От попыток сделать обновление самоцвета sudo для других проблем получая это сотни раз, как ...

Задан 25 Jan 2012, 15:00 от Michael Durrant
  • 13 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Я бы сказал, просто поставить «iconv» один раз, где-нибудь, как вопрос стиля. Хороший вопрос ... нам не нужны рубины!

ли решение использоватьString.force_encoding() в Ruby 1.8.7 (или Rails 2.x), чтобы он работал как в Ruby 1.9? Я читал что-то о требоватьactive_support, но это не работает $3$gt;список драгоценных камней --local | grep 'rails \ | ...

Задан 03 Jan 2011, 11:06 от Fu86
  • 2 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

 или же

аждогоgem выполнение я получаю следующую ошибку: Invalid gemspec in [...rvm/gems/ruby-1.9.2-p136/specifications/webrobots-0.0.10.gemspec]: invalid date format in specification: "2011-07-01 00:00:00.000000000Z"Я не сопровождающий веб-роботов, и я ...

Задан 08 Aug 2011, 23:14 от lbz
  • 9 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

У меня была такая же проблема после обновления до OS X Lion. Я обновил X Code до 4.1 и все стало лучше!

учаю следующее при запуске "$ bundle" после добавления "gem 'redcarpet'" в Gemfile: $ bundle ... Using paperclip (2.3.11) Using passenger (3.0.7) Installing redcarpet (1.17.2) with native ...

Задан 01 Jul 2011, 16:14 от robertwbradford
  • 15 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Можно ли загрузить драгоценный камень Ruby, не устанавливая его автоматически?

Когда я загружаю что-то, используяgem Я хотел бы иметь возможность просто скачать гем, а затем выбрать, хочу ли я установить его. Я спрашиваю об этом, потому что я хотел бы установить конкретный драгоценный камень на более чем один компьютер (без ...

Задан 09 Sep 2009, 19:40 от Geo
  • 2 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Проблема шифрования пароля в Rails Devise gem

Сейчас я изменил использование Gem Devise для аутентификации пользователей. Но я не знаю, как подобрать шифрование!Я знал, что мы могли бы написать новый шиф...

Задан 16 Aug 2010, 09:42 от PeterWong
  • 2 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Отлично, только что обновил до 3.0.7 все отлично работает. Спасибо большое.

совершенно новичок в Rails и только начал создавать свой первый проект, следуя инструкциям учебника. Я создал новый проект, используя:rails myapp. Тогда я должен выполнитьbundle install, это не сработало, потому что не был установлен bundler, ...

Задан 05 May 2011, 10:22 от john84
  • 3 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Показать категории / подкатегории в древовидной иерархии внутри выпадающего

У меня есть таблица категорий с полями id, name и parent_id. Корневые категории имеют parent_id 0. Теперь я хочу показать список категорий в раскрывающемся с...

Задан 07 Sep 2015, 15:36 от manoj
  • 15 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

 покажет вам, что блокирует версию:

аюсь указать версиюхозяйственный камень [http://rubygems.org/gems/thrift]в моем файле драгоценного камня. gem 'thrift', "~> 0.6.0"Когда я пытаюсь бежатьbundle installЯ получаю эту ошибку: You have requested: thrift ~> 0.6.0 The bundle currently ...

Задан 08 Mar 2011, 11:38 от ben
  • 0 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Требовать самостоятельно сделанный драгоценный камень в jruby не удается после обновления до jruby-1.7.13

Я использовал jruby-1.7.0 и тестировал работу фрейма Test :: Unit :: TestCase. Теперь я обновил некоторые гемы, которые заставили меня использовать MiniTest ...

Задан 13 Aug 2014, 14:24 от user2025166
  • 13 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Переход на MySQL 5.1, возможно, самый простой маршрут, если это возможно.

ибудь получил MySQL Gem 2.8.1. работает на OSX 10.7? Я установил MySQL 5.5.13 64bit и попробовал следующее после успешной установки MySQL: env ARCHFLAGS="-arch x86_64" gem install mysql -v='2.8.1' -- --with-mysql-dir=/usr/local/mysql ...

Задан 14 Jun 2011, 07:08 от sdepold
  • 12 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

 уважает зависимости, так что это не разрешит конфликт.

ьзуя Rails 3, я пытаюсь понять, что, по моему мнению, должно быть довольно простым ... У меня есть 2 драгоценных камня, которые требуют 2 разных версий одной и той же зависимости от драгоценных камней. Обе версии зависимого гема установлены в ...

Задан 26 May 2011, 00:21 от ericalli
  • 18 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Чистый минимальный драгоценный камень, чтобы добавить простой блог в существующее приложение? [закрыто]

Мне нужен блог внутри моего существующего приложения, но он не должен быть модным, некоторые категории и способ преобразования каталога текстиля в посты блога, включая дату, подойдут, уже искал это, но ничего необычного не пришло. какие-нибудь ...

Задан 14 Feb 2012, 11:36 от Rubytastic
  • 19 голосов
  • 4 ответа
  • 0 просмотров
4 ответа

Ошибка установки Rails «неверный гем: пакет поврежден»

Я использую Mac OSX 10.9.1 и использую RVM для управления Ruby v2.0.0-p353.Когда я пытаюсь установить Rails, я получаю эту ошибку:

Задан 31 Dec 2013, 01:16 от ryan
  • -2 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Прай это не модуль

Хорошо, как спросил @ tim-moore, я опубликую это в новом вопросе. Итак, я хотел сделать драгоценный камень, используя комплект. Pry расширение драгоценного камня требует, чтобы камень начинался сpry- как уже ...

Задан 10 Nov 2013, 12:14 от Darek Nędza
  • 5 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

нет такого файла для загрузки - стойка

Иногда, мое приложение rails выдает ошибку (нет такого файла для загрузки в стойку), даже если стойка установлена. [Gemfile] gem 'rack', '1.2.1' Если я обновлю страницу, она загрузится нормально. Так что это не проблема драгоценного камня. Что ...

Задан 12 Jan 2012, 04:09 от Sam Kong
  • 8 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

gem install json завершается неудачно с переопределением структуры timezone / timespec

Я на Windows с Ruby 1.9.3 с DevKit (все 32-разрядные на Win 7 64-разрядных). Сейчас я пытаюсь установить рельсы, но получаю ошибку из комплекта. Если я попыт...

Задан 27 Feb 2013, 19:00 от Henno
  • 221 голос
  • 8 ответов
  • 0 просмотров
8 ответов

Как я могу найти, где установлены гем-файлы?

Я могу найти, какой драгоценный камень установлен командойgem list, но это не показывает мне, где драгоценные камни установлены. Как я могу найти, где находятся драгоценные камни, и как я могу узнать перед установкой драгоценного камня, где он ...

Задан 28 Sep 2013, 21:54 от ironsand
  • 6 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

я думаю, что на последней версии nokogiri, она автоматически разрешит правильную версию с помощью gem install и bundle install

я эта проблема с жемчужиной Нокогири: Не удалось открыть библиотеку 'C: \ Ruby187 \ lib \ ruby ​​\ gems \ 1.8 \ gems \ nokogiri-1.4.6-x86-mingw32 \ ext \ nokogiri \ libxml2.dll': неизвестно Я прочитал, что я должен был попробовать версию ...

Задан 23 Jun 2011, 14:30 от tiiin4
  • 200 голосов
  • 16 ответов
  • 0 просмотров
16 ответов

Установка libv8 gem на OS X 10.9+

Я пытаюсь установить libv8 3.16.14.3, но получаю ошибку на OSX Mavericks с использованием последних стабильных версий rvm и ruby-1.9.3-p125. Это результат выполнения команды 'gem install libv8': ~/src(branch:master) » gem install libv8 ...

Задан 24 Oct 2013, 22:17 от tanookiben
  • 5 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Выяснение того, какое приложение Gems Rails не использует

Работа над приложением, которое имеет почти 200 драгоценных камней. Кто-нибудь выяснил, как выделить драгоценные камни, которые не используются, чтобы их можно было извлечь из смеси.

Задан 20 Mar 2012, 19:11 от thenengah
  • 6 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Невозможно установить mysql2 gem OS X Mountain Lion

Я новичок в RoR, и я пытаюсь установить Mysql2 -v "0.3.11". У меня OS X Mountain Lion, рельсы 3.2.6, ruby 1.9.3. Ниже приведена ошибка, которую я получаю. Я...

Задан 14 Aug 2012, 03:33 от yabenjo
  • 19 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

В чем разница между гемами "open-uri" и "Net: HTTP" в Ruby?

Кажется, что оба этих драгоценных камня выполняют очень похожие задачи. Кто-нибудь может привести примеры, где один драгоценный камень будет более полезным, чем другой? У меня нет конкретного кода, на который я ссылаюсь, я больше интересуюсь ...

Задан 26 May 2013, 21:54 от Richie Thomas
  • 34 голосов
  • 16 ответов
  • 0 просмотров
16 ответов

Установка Ruby MYSQL2 gem на Windows 7

Я пытаюсь установить gem mysql2 на windows 7 Я скачал коннектор с сайта mysql и поместил libmysql.dll в ruby200 \ bin тогда сделай gem установи mysql2 Это результаты, я неясен? Temporarily enhancing PATH to include DevKit... Building native ...

Задан 25 Sep 2013, 19:58 от Mrk Fldig
  • 28 голосов
  • 5 ответов
  • 0 просмотров
5 ответов

Рубиновый камень для поиска часового пояса

У меня есть местоположение (город, штат), дата и время, и я хочу преобразовать его в utc, но сначала нужно найти часовой пояс местоположения. Я провел небольшое исследование, и все, кажется, указывает либо на earthtools, либо на geonames, но оба ...

Задан 01 Dec 2011, 23:24 от Nick
  • 10 голосов
  • 5 ответов
  • 0 просмотров
5 ответов

Ошибка установки Rails: «атомарный» собственный гем требует установленных инструментов сборки [дубликат]

На этот вопрос уже есть ответ здесь: Собственный камень json требует установленных инструментов сборки [/questions/8100891/the-json-native-gem-requires-installed-build-tools] 8 ответовЯ устанавливаю Rails 3 на мои окна. Я установил последний ...

Задан 06 Jul 2013, 05:20 от Tatarao voleti
  • 0 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Не удается установить JSON Gem в Windows

Я пытался установить JSON Gem на Windows. Я установил DevKit. Я получаю следующую ошибку ниже. Какие-либо предложения? Этот вопросJSON Gem не будет установле...

Задан 17 Apr 2013, 20:11 от TinyGrasshopper
  • 14 голосов
  • 5 ответов
  • 0 просмотров
5 ответов

Развертывание Heroku не удалось из-за ошибки gem sqlite3

Я только что начал книгу Майкла Хартла ruby.railstutorial.org и прорабатывал первую главу. Я использую MacBook OS X, Терминал и Sublime Text. Все шло по план...

Задан 26 Oct 2012, 06:28 от xuamox
  • 2 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Push-уведомления Ruby on Rails

Есть ли что-то, что я могу использовать для отправки уведомлений с сервера в веб-приложение в приложении Rails?Это означает, что время от времени не нужно вы...

Задан 02 Jan 2014, 16:56 от tostasqb
  • 2 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Просто не могу заставить Redmine работать

Итак, я пытался заставить Redmine работать со всеми видами учебников в Интернете, но я всегда застреваю на одном и том же шаге: G:\Ruby187\apps\redmine>rake db:migrate NOTE: SourceIndex.new(hash) is deprecated; From ...

Задан 20 Sep 2011, 12:40 от Yash Desai
  • 33 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Используйте приложение Gemset for Rails

разница между плагинами и гемами? Каковы различные варианты использования каждого из них? Где и почему вы используете один поверх другого?

Задан 02 Apr 2011, 04:45 от Mr. Black
Page 1 of 6
1 2 3 4 5