Лучшие ubuntu вопросы ИТ разработчиков

  • 6 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

 и будет много помощи, чтобы сделать это.

ановил sendmail с PHP и apache на Ubuntu. Когда я пытаюсь следующую командную строку php -r "mail('[email protected]', 'test', 'test')"'он успешно отправляет электронное письмо. Тем не менее, запустив файл "test_send_mail.php" с: <?php ...

Задан 06 Jul 2011, 02:28 от Tim
  • 24 голосов
  • 5 ответов
  • 0 просмотров
5 ответов

Virtualenv на Ubuntu без сайтов-пакетов

В последнее время я использую virtualenv при разработке на python. Мне нравится идея отдельной среды разработки с использованием опции --no-site-packages, но...

Задан 30 Oct 2008, 04:32 от Jeremy Cantrell
  • 10 голосов
  • 5 ответов
  • 0 просмотров
5 ответов

MariaDB не может запуститься после обновления: [Предупреждение] Не могу создать тестовый файл /home/mysql/beta.lower-test

Я только что обновил MariaDB, используя apt-get dist-upgrade. Теперь он не начнет использоватьслужба mysql start больше.Однако я могу запустить его как root ...

Задан 22 Jul 2016, 14:39 от Bento
  • 4 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Невозможно отправить git-репо через HTTP

Я за брандмауэром, который позволяет только HTTP / HTTPS. Хотя я могу получить git-репозитории через HTTPS, я не могу их протолкнуть через HTTP / HTTPS. Хотя репозиторий размещен на github, что позволяет, я получаю сообщение об ошибке. Вот ...

Задан 11 Feb 2012, 19:34 от hytriutucx
  • 11 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

имя 'get_config' не определено

когда я работаю с ноутбуком ipython, я хочу запустить сервер ноутбука. Я следовал за официальнымруководство Тем не менее, когда я хочу получить

Задан 27 Dec 2014, 09:54 от zishuiym
  • 1 голос
  • 0 ответов
  • 0 просмотров
0 ответов

Рейк отменен: не удалось найти rspec

Я пытаюсь проработать курс Ruby от TestFirst.org. Он требует, чтобы вы перешли в папку, содержащую упражнение, запустили rake, а затем исправили все ошибки в...

Задан 11 Jun 2014, 22:09 от Jayson Virissimo
  • 10 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

Уменьшите трехсекундную задержку до нуля. Решение 1 (клиент = ноль):

оды обеспечивают отправку данных по протоколу пользовательских дейтаграмм. Ниже приведены два кода. Когда я использую первый код для недоступного IP-адреса, ...

Задан 22 Jun 2017, 08:25 от Salih Karagoz
  • 14 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Я хотел бы добавить (поскольку я пока не могу комментировать), что для фактического решения этой проблемы вам нужно добавить ваш локальный bashrc, иначе, каждый раз, когда вы открываете терминал, экспорт исчезает.

отаю над проектом Python с OpenCV на ОС Ubuntu import numpy as np import cv2 img = cv2.imread("LillyBellea.png", 1) img = cv2.imwrite("LillyBellea.jpeg", img) cv2.imshow("original", img) cv2.waitKey(0) cv2.destroyAllWindows()когда я запускаю эту ...

Задан 05 Jul 2017, 19:38 от Bhushan Uniyal
  • 20 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

pcntl не работает на Ubuntu «по соображениям безопасности»

Я установил pcntl на моем PHP 5.4.6, работающем на Ubuntu 32-bit 12.10, используяэто [http://www.crimulus.com/2010/07/30/howto-enable-pcntl-in-ubuntu-php-installations/] статья. Все пошло не так гладко, потому что после компиляции при ...

Задан 28 Apr 2013, 12:28 от Oleg Belousov
  • 54 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

Python ImportError не может импортировать urandom После обновления Ubuntu 12.04

Обновлен Ubuntu до Precise Pangolin (12.04), и Python's Random теперь не работает ... Я подозреваю, что другие вещи тоже могут быть повреждены. Как мне испра...

Задан 28 Apr 2012, 20:22 от xxjjnn
  • 31 голос
  • 0 ответов
  • 0 просмотров
0 ответов

Подлинность хоста "github.com (192.30.252.128)" не может быть установлена

Я пытаюсь использовать sudo npm installустановить все мои зависимости для приложения, написанного на nodejs. Моя ОС - Ubuntu 13.04 Тем не менее, я продолжаю получать это предупреждение: The authenticity of host 'github.com (192.30.252.131)' ...

Задан 10 Sep 2013, 03:07 от led
  • 5 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Запускать несколько узлов эластичного поиска в качестве службы на одном Ubuntu-сервере

У меня есть сервер под управлением Ubuntu 14.04 с 220 ГБ оперативной памяти, на котором я хотел бы запуститьasticsearch. Согласно документации, один узел не ...

Задан 02 Oct 2014, 14:09 от user167172
  • 23 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

У меня ничего не работает. Я испробовал каждое решение, но ни одно из них не сработало. В какой версии Ubuntu эта ошибка была устранена, чтобы я просто установил ее и удалил то, что у меня есть?

ользую Ubuntu 16.04, который поставляется с python2.7 и python3.5. Поэтому я установил Python3.6 на него и symlink Python3 на Python3.6 черезalias python3=python3.6, Затем я установил virtualenv используяsudo -H pip3 install virtualenv, И когда я ...

Задан 14 Dec 2017, 22:00 от wgetDJ
  • 17 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Вы также можете сразу использовать PHAR после его загрузки;

читал другие вопросы по установке PHPUnit, но безуспешно. Что происходит с моей установкой PEAR? $ sudo pear update-channels Updating channel "components.ez.no" Channel "components.ez.no" is up to date Updating channel "doc.php.net" ...

Задан 06 Jul 2011, 12:25 от Greg K
  • 6 голосов
  • 1 ответ
  • 0 просмотров
1 ответ

Apache / Rails / Passenger Отображение индекса сайта?

У меня есть приложение Rails, которое я успешно протестировал с Mongrel и Webkit. Теперь я хочу протестировать развертывание. Я установил образ VMWare, используя Ubuntu 8.04. Я установил Rails, следуя этому ...

Задан 30 Sep 2008, 20:35 от JP Richardson
  • 10 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

Запуск докера в Ubuntu: смонтированный том хоста недоступен для записи из контейнера

Docker отлично работает на Mac для меня, но я должен запустить Docker Host внутри VirtualBox (или Parallels, или VMWare Fusion), так как ядро ​​Mac не поддер...

Задан 01 Dec 2015, 22:25 от Alex Kovshovik
  • 5 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

Ошибка компоновщика Lunatic Python lua.require ('socket') -> неопределенный символ: lua_getmetatable

У меня есть проект на Python, основанный на некоторых файлах lua, один из которых требует 'socket'. Я получаю сообщение об ошибке загрузки socket.core "undefined symbol: lua_getmetatable", когда пытаюсь запросить этот файл lua из python ...

Задан 02 Dec 2011, 19:20 от RedCup
  • 35 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

 CMD для Linux.

ичок здесь, и это мой первый пост.У меня проблема с Bash на Ubuntu в Windows. Если я набираю «open (filename)» в терминале Mac, он открывает файл с нужной пр...

Задан 26 Feb 2017, 02:09 от Pets
  • 8 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Есть ли какие-либо проблемы с запуском Eclipse с OpenJDK под Linux?

Стандартное решение для исправления проблем с Java в дистрибутивах Linux, таких как Ubuntu, - сказать «Используйте Sun JDK вместо OpenJDK». По нескольким причинам я хотел бы просто использовать поставку Java с Ubuntu вместо того, чтобы ...

Задан 14 Nov 2011, 14:37 от Thorbjørn Ravn Andersen
  • 1 голос
  • 1 ответ
  • 0 просмотров
1 ответ

Ошибка команды оболочки php GLIBCXX_3.4.9 не найден

Я пытаюсь выполнить команду оболочки из PHP для преобразования файлов в PDF, но я получаю эту ошибку. Может кто-нибудь подробно объяснить мне, как это исправить? Я не так хорош в Linux ( а также, если я выполняю команду прямо через терминал, все ...

Задан 22 Dec 2013, 11:49 от KoSMoS
  • 1 голос
  • 1 ответ
  • 0 просмотров
1 ответ

g ++ и ошибка компоновщика буста в Ubuntu oneiric

Я получаю следующие ошибки после обновления. Я не могу понять, что с ним не так. Это должно работать, насколько я вижу. $ make 2>&1 | head g++ -o prog -ansi -O2 -Wall -I/usr/include/boost -L/usr/lib -lboost_program_options -lboost_thread ...

Задан 14 Oct 2011, 09:15 от Sardathrion
  • 1 голос
  • 0 ответов
  • 0 просмотров
0 ответов

rails server bin / rails: 6: предупреждение: уже инициализирована постоянная ошибка APP_PATH

Я использую Ubuntu 14.04, и я новичок в использовании Ruby on RailsЯ недавно установил rbenv, ruby ​​2.3.0 и rails 4.2.4, следуя инструкциям:https://gorails....

Задан 07 Mar 2016, 18:19 от marsty5
  • 7 голосов
  • 3 ответа
  • 0 просмотров
3 ответа

Как вручную установить плагин eclipse-CDT из архива / zip в Ubuntu?

Я успешно установил Eclipse 3.5 и Java 1.5. Я хотел бы установить CDT без использования Eclipse&#39;s &quot;установить новые функции &quot; (также я не могу ...

Задан 07 Sep 2009, 18:58 от Trevor Boyd Smith
  • 2 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

, это может быть полезно для вас.

я есть два сценария - основной, который делает несколько разных вещей и вызывает второй сценарий, и второй сценарий, который устанавливает MySQL. Из моего основного сценария я делаю что-то вроде этого: ... read -p "Set the password for the ...

Задан 26 Oct 2017, 13:29 от Dugi
  • 71 голос
  • 2 ответа
  • 0 просмотров
2 ответа

Как посчитать количество файлов в каждом каталоге?

Я могу перечислить все каталоги по find ./ -type dЯ попытался составить список содержимого каждого каталога и подсчитать количество файлов в каждом каталоге, используя следующую команду find ./ -type d | xargs ls -l | wc -lНо это сумма общего ...

Задан 05 Mar 2013, 05:18 от user784637
  • 10 голосов
  • 0 ответов
  • 0 просмотров
0 ответов

update-alternatives создает, удаляет, поддерживает и отображает информацию о символических ссылках, составляющих систему альтернатив Debian.

аюсь установить свои пакеты composer, но это дает мне это: This package requires php >=7.0.0 but your PHP version (5.5.9) Ноphp -v дает мне это:PHP 7.0.22-0ubuntu0.16.04.1 (cli) ( NTS ) Я работаю на машине с Ubuntu 16.04.3 LTS, я нашел ...

Задан 28 Aug 2017, 07:46 от PrimuS
  • 1 голос
  • 3 ответа
  • 0 просмотров
3 ответа

Android делает сбой на Ubuntu

Попытка собрать проект с открытым исходным кодом Android на Ubuntu 10.04 (на VMware Player).Я следовал инструкциям наэта ссылка (и он сказал использовать sun...

Задан 07 Sep 2010, 17:46 от jotobjects
  • 2 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

как мне обновить cuDNN до более новой версии?

руководство по установке cuDNN гласитВСЕ ПЛАТФОРМЫРаспакуйте архив cuDNN в каталог по вашему выбору, именуемый ниже как. Затем следуйте инструкциям для конкр...

Задан 01 Jul 2016, 05:42 от dontloo
  • 4 голосов
  • 2 ответа
  • 0 просмотров
2 ответа

 в изобилии

могу обновить несколько Mercurial (hg) репозиториев из каталога их общего родителя? /plugins/search /plugins/overview /plugins/chartЯ хочу изменить ветку по умолчанию и обновить их все сразу cd /plugins/search hg update -C default hg pull -u

Задан 22 Nov 2017, 11:53 от Sergii Tanchenko
Page 2 of 27